MikroTik. Wake on Lan

24 Апр
2012

Однажды на работе (а работаю я системным администратором в небольшой компании) подошел рядовой сотрудник и спросил — “Могу ли я удаленно зайти на свой компьютер предварительно его включив?”. Насчет удаленного доступа все давно отлажено, а вот со включением все намного интереснее. На тот момент был дан простой ответ — “Не выключай свой компьютер”. Когда с подобным вопросом подошел второй сотрудник, я озадачился данным вопросом.
В основе сети стоит железка от MikroTik. В функциях данного маршрутизатора в принципе есть функция wol, вызывается из терминала:
[admin@MikroTik] > tool wol interface=ether1 mac=FF:FF:FF:FF:FF:FF


Разумеется давать доступ сотрудникам к админке MikroTik, для пробуждения компьютера — самая худшая идея. Тревожить админа во внерабочее время тоже не особо хорошо. Поэтому был найден максимально универсальный метод, который в явном виде не был нигде описан.
Настройка MikroTik укладывается всего в несколько шагов. В качестве офисной сети используется диапазон 192.168.1.0/24. Настройку компьютера/BIOS/сетевая карта опустим.

1. Создаем статическую запись в ARP таблице для broadcast
[admin@MikroTik] > /ip arp add address=192.168.1.254 disabled=no interface=bridge-local mac-address=FF:FF:FF:FF:FF:FF


2. Создаем статическую запись в ARP таблице для компьютера пользователя
[admin@MikroTik] > /ip arp add address=192.168.1.2 disabled=no interface=bridge-local mac-address=00:1D:60:B4:B3:2C


3. Создаем правило в IP FIREWALL NAT для проброса порта
[admin@MikroTik] > /ip firewall nat add action=dst-nat chain=dstnat comment="to broadcast WOL" disabled=no dst-port=4321 protocol=udp to-addresses=192.168.1.254 to-ports=9


После выполнения всех шагов сотруднику достаточно дать строку на depicus.com вида
www.depicus.com/wake-on-lan/woli.aspx?m=001D60B4B32C&i=82.110.108.30&s=255.255.255.255&p=4321


где выделено соответственно MAC адрес компьютера, внешний IP офисного маршрутизатора и порт.
Либо для особо продвинутых можно использовать программы на IPHONE, ANDROID устройстваx с использованием тех же IP, MAC, порт.

При появлении новых сотрудников достаточно повторить шаг 2, с указанием следующего IP и MAC адреса его компьютера либо просто сделав эту запись статической при включенном компьютере.

P.S. Как ни странно фунция Wake on Lan over internet есть во многих домашних роутерах, и альтернативных прошивках для них dd-wrt и т.п.

В качестве источников информации были использованы следующие материалы:
1. Официальная Wiki
2. Официальный форум MikroTik
3. Форум Олега по роутерам ASUS
По материалам Хабрахабр.



загрузка...

Комментарии:

Наверх